Infrastructure Instability across servers

Incident Report for Thomson Reuters Corporates

Resolved

This incident has been resolved.
Posted Mar 25, 2026 - 09:24 CDT

Identified

To resolve some infrastructure instability, we are performing some emergency maintenance. This emergency maintenance may cause temporary performance degradation for a subset of clients. This degradation could last for 30 minutes following the maintenance which will occur between 3/24/2026 2:30pm and 3/24/2026 3:00pm
Posted Mar 24, 2026 - 14:59 CDT
This incident affected: Trust & Info Rptg (AMERS Tax Information Reporting).