AMERS GoSystem Tax RS causing blank screen to display

Incident Report for Thomson Reuters Corporates

Resolved

This incident has been resolved.
Posted Sep 14, 2026 - 00:35 CDT

Investigating

We are currently investigating an issue with AMERS GoSystem Tax RS that is causing a blank screen to display. Our team is actively working on it and will provide an update once the issue has been fixed.
Posted Sep 13, 2026 - 23:20 CDT
This incident affected: Direct Tax (AMERS GoSystem Tax RS).