User Administration [AMERS]
Incident Report for Thomson Reuters Corporates
Resolved
This issue has been resolved and the application is currently working for all clients
Posted Jun 24, 2022 - 18:05 CDT
Update
We are continuing to investigate this issue.
Posted Jun 24, 2022 - 18:04 CDT
Investigating
The User Administration application is experiencing Performance degradation.
Posted Jun 24, 2022 - 12:41 CDT
This incident affected: WorkFlow Tools (AMERS User Administration).