We are investigating reports that some customers cannot open GST returns.

Incident Report for Thomson Reuters Corporates

Resolved

This incident has been resolved.
Posted Jan 29, 2026 - 10:33 CST

Monitoring

We are currently experiencing intermittent issues with the GoSystem Tax RS Browser. Our team is actively working to resolve this matter as quickly as possible. We apologize for any inconvenience and appreciate your understanding and patience.

Further updates will be provided here as soon as we have more information. If you have any questions, please contact Customer Support.
Posted Jan 28, 2026 - 16:12 CST
This incident affected: Direct Tax (AMERS GoSystem Tax RS).