Welcome to the Thomson Reuters Corporate Tax and Trade Status page – This is the centralized resource for real-time visibility into the performance and availability of all Thomson Reuters Corporate Tax and Trade products.
This portal provides updates on service status, ongoing incidents, scheduled maintenance, and performance issues across our Corporate Tax and Trade product suite. Our goal is to keep you informed with timely, accurate information so you can plan your work accordingly.
For proactive notifications, subscribe to updates to receive alerts about status changes and incidents affecting your specific Corporate Tax and Trade products.
Get email notifications whenever Thomson Reuters Corporates creates, updates or resolves an incident.
Get text message notifications whenever Thomson Reuters Corporates creates or resolves an incident.
Get webhook notifications whenever Thomson Reuters Corporates creates an incident, updates an incident, resolves an incident or changes a component status.
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 04, 2025 - 00:00 CDT
Scheduled
Thomson Reuters will be performing a scheduled maintenance on Sunday, May 4th 2025, beginning at 1:00 am Eastern with a duration of 17 hours. This maintenance will include Windows Updates and apply any other required patches to the TEST/IMPLEMENTATION and PRODUCTION environments and will be performing migrations and activities related to improvement projects. During this maintenance period there will intermittent downtimes, and you will not be able to access your Test/Implementation or Production instances.
Posted Apr 22, 2025 - 10:26 CDT
This scheduled maintenance affected: Global Trade (Global Trade Content, Global Trade - pwd by Integration Point, Govt Connectivity BE - PLDA, Govt Connectivity DE - ATLAS, Govt Connectivity FR - DELTA, Govt Connectivity MX - SAAI/COVE, Govt Connectivity NL - AGS, Govt Connectivity UK - CHIEF/CDS, Govt Connectivity US - ABI/AES, GTM Platform, Implementation Environment, Transports AS2, Transports Client Interchange Web Service, Transports FTP).