Some GST users are getting authentication errors when logging in

Incident Report for Thomson Reuters Corporates

Resolved

This incident has been resolved.
Posted Aug 15, 2025 - 11:16 CDT

Investigating

We are currently experiencing intermittent issues with the Gosystem Tax login error feature, some customers are receiving an error message when trying to login in. Our team is actively working to resolve this matter as quickly as possible. We apologize for any inconvenience and appreciate your understanding and patience.

Further updates will be provided here as soon as we have more information. If you have any questions, please contact Customer Support.
Posted Aug 15, 2025 - 10:54 CDT
This incident affected: Direct Tax (AMERS GoSystem Tax RS).