Corporate Tax - workbook service

Incident Report for Thomson Reuters Corporates

Resolved

This incident has been resolved.
Posted Dec 22, 2025 - 08:59 CST

Investigating

We're aware of issues being seen when attempting to open calculations. Users may experience an unknown exception occurred error.

This is being investigated by the appropriate teams.

We apologise for the inconvenience.
Posted Dec 22, 2025 - 08:41 CST
This incident affected: Direct Tax (EMEA (web) Corporate Tax).