ONESOURCE Global Trade -- FTZ Validations Issue

Incident Report for Thomson Reuters Corporates

Resolved

This issue has been resolved. We will continue to monitor for the next few hours.
Posted Mar 19, 2025 - 14:51 CDT

Identified

Thomson Reuters has identified an issue with validations that is affecting all FTZ customers. Customers may see degradation in performance or timeouts when working to complete validations in the FTZ application. We are working on a resolution now.
Posted Mar 19, 2025 - 10:50 CDT
This incident affected: Global Trade (Global Trade - pwd by Integration Point, GTM Platform).