Uncertain Tax Position is Unavailable in AMER Region

Incident Report for Thomson Reuters Corporates

Resolved

This incident has been resolved.
Posted Apr 14, 2025 - 19:16 CDT

Investigating

Users are unable to access UTP in the AMER Region. The team is currently looking into this issue.
Posted Apr 14, 2025 - 14:37 CDT
This incident affected: Direct Tax (AMERS Uncertain Tax Positions).