Direct Tax - Change Failure
Incident Report for Thomson Reuters Corporates
Resolved
This incident has been resolved.
Posted Jul 19, 2024 - 03:59 CDT
Identified
During the planned release, we faced some issues and rolling back the application to previous state.
Posted Jul 19, 2024 - 03:08 CDT
This incident affected: Direct Tax (EMEA (web) Corporate Tax, EMEA (web) E-filing Manager (Corporate Tax)).