Indirect Tax Delay in Data for reports and analytics service in AMER PROD

Incident Report for Thomson Reuters Corporates

Resolved

This incident has been resolved.
Posted Jan 18, 2026 - 12:14 CST

Investigating

We are experiencing delay of ~10 hours in processing the Reports and Analytics Enterprise Cloud data, we are working on the catch up.
Posted Jan 18, 2026 - 05:10 CST
This incident affected: Indirect Tax (Reports and Analytics Enterprise Cloud).