Maintenance Extension till 05/24/2026 6 AM CT

Incident Report for Thomson Reuters Corporates

Resolved

This incident has been resolved.
Posted May 24, 2026 - 03:25 CDT

Investigating

We are currently experiencing intermittent issues with Launching of Tax Provision for few clients with our Tax Provision service.
Posted May 23, 2026 - 19:02 CDT
This incident affected: Direct Tax (AMERS Tax Provision).