Increased Latency and Intermittent failures for Tax calls in AMER PROD

Incident Report for Thomson Reuters Corporates

Resolved

The issue has been mitigated for Tax Calculation service in AMER PROD at 03:32 PM EST. Please update the status page back to green.
Posted Nov 18, 2025 - 16:03 CST

Investigating

Intermittent Issues: We are currently experiencing intermittent issues with the Tax Calculations feature with our ONESOURCE Determination Enterprise Cloud service.
Posted Nov 18, 2025 - 10:03 CST
This incident affected: Indirect Tax (ONESOURCE Determination Enterprise Cloud (AWS AMER)).