Case Management Dashboard service

Incident Report for Thomson Reuters Corporates

Resolved

This incident has been resolved.
Posted Sep 16, 2026 - 10:08 CDT

Investigating

Dear Customer,

We are currently experiencing a global outage affecting Salesforce, the system we use to manage and track support cases.

Please be assured that our Support team remains available and committed to assisting you. While the outage is ongoing, we can still support you via phone. We will document the details of your issue manually and create an official support case in Salesforce as soon as service is restored.

We apologise for any inconvenience and appreciate your patience and understanding. We will continue to address your requests as quickly as possible and keep you informed of any significant updates.

Thank you for your patience.

Thomson Reuters Support Team
Posted Sep 16, 2026 - 05:05 CDT
This incident affected: Customer Support (Case Management Dashboard).