DataFlow NextGen - Roll Forward, Batch Recalc delayed processing

Incident Report for Thomson Reuters Corporates

Resolved

This incident has been resolved.
Posted Jun 16, 2026 - 12:55 CDT

Investigating

Slow Performance: We are currently experiencing a performance issue with the Roll Forward, Batch Recalc feature with our Roll Forward, Batch Recalc service.
Posted Jun 16, 2026 - 07:34 CDT
This incident affected: Data Tools (AMERS DataFlow).