Calculation Module – Intermittent Access Disruption

Incident Report for Thomson Reuters Corporates

Resolved

This incident has been resolved.
Posted Aug 20, 2025 - 11:11 CDT

Investigating

We are currently experiencing intermittent issues with the calculation feature. Users may encounter an 'Unknown Error' banner when attempting to open or work within the calculation module.
Posted Aug 20, 2025 - 09:48 CDT
This incident affected: Direct Tax (EMEA (web) Corporate Tax).