Certificate Manager Original Cloud
Incident Report for Thomson Reuters Corporates
Resolved
This issue has been resolved and the application is currently working for all clients
Posted May 20, 2022 - 07:56 CDT
Investigating
Some customers are unable to access the Certificate Manager. We are currently investigating this issue.
Posted May 19, 2022 - 09:27 CDT
This incident affected: Indirect Tax (Certificate Manager Original Cloud).