Onesource Global Trade Management -- Login Issue

Incident Report for Thomson Reuters Corporates

Resolved

This incident has been resolved.
Posted May 28, 2026 - 10:49 CDT

Monitoring

Issue has been resolved and all clients should be able to login. We will continue to monitor.
Posted May 26, 2026 - 15:50 CDT

Investigating

Thomson Reuters is investigating an issue where clients are not able to login to the application. We are actively working to get access restored.
Posted May 26, 2026 - 15:36 CDT
This incident affected: Global Trade (Global Trade - pwd by Integration Point, GTM Platform).