Global Trade – Pwd by Integration Point - Service Disruption
Incident Report for Thomson Reuters Corporates
Resolved
This issue has been resolved and the application is currently working for all clients
Posted May 12, 2021 - 09:54 CDT
Investigating
We have received reports that Global Trade – Pwd by Integration Point is in a degraded state and our teams are investigating now.
Posted May 12, 2021 - 08:59 CDT
This incident affected: Global Trade (Global Trade - pwd by Integration Point).