General Ledger Manager [AMERS]
Incident Report for Thomson Reuters Corporates
Resolved
This issue has been resolved and the application is currently working for all clients
Posted Jun 04, 2023 - 19:39 CDT
Investigating
The General Ledger Manager application is experiencing performance issues in Import modules and we are actively investigating it. We will post an update once resolved.
Posted Jun 02, 2023 - 12:47 CDT
This incident affected: Data Tools (AMERS General Ledger Manager).