ONESOURCE Global Trade -- Intermittent workflow slowness

Incident Report for Thomson Reuters Corporates

Resolved

This incident has been resolved.
Posted Dec 29, 2025 - 15:30 CST

Investigating

Thomson Reuters is currently investigating an intermittent issue with the workflow performance. Clients may notice some delays in their processing. We are working to address the intermittent issues now and will update once resolved.
Posted Dec 29, 2025 - 13:06 CST
This incident affected: Global Trade (Global Trade - pwd by Integration Point).