Customer Support [Direct Tax, Global Trade, Indirect Tax] - Service Disruption
Incident Report for Thomson Reuters Corporates
Resolved
This issue has been resolved and the application is currently working for all clients
Posted Jul 25, 2024 - 03:31 CDT
Investigating
We have received reports that Customer Support [Direct Tax, Global Trade, Indirect Tax] has an intermitted issue and our teams are investigating now.
Posted Jul 25, 2024 - 02:30 CDT
This incident affected: Customer Support (Direct Tax, Global Trade, Indirect Tax).